Return to Home page

Search | Statistics | User Listing Forums | Calendars | Albums | Quotes Forum ->  General discussion -> Technical Discussion -> View Thread

You are logged in as a guest. ( logon | register )

Random quote: Be silent as to services you have rendered, but speak of favours you have received.>Seneca<

electrical failure
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   General discussion -> Technical DiscussionMessage format
Posted 4/23/2005 10:44 PM (#7409)
Subject: electrical failure

I now have the sidecar mounted and got the body on the frame. Was getting ready to hook up the wiring to the sidecar. Had the ignition key on, but did not start the bike, as I used a tester on the plug from the bike that will connect to the sidecar to see what wire was what when all of the lights on the bike went off. I turned the key back on several times and nothing happened, just a faint abs light in the console nothing else lights up. Tried a booster box with no luck and even put it on the charger. Still nothing, what did I do and how do I fix it???The bike is a 1989 BMW K-100 LT. Battery tests hot, I've loosened and retightened all battery cables and checked the bike ground wire to the frame. What else is there??

Top of the page Bottom of the page
Posted 4/25/2005 7:40 AM (#7421 - in reply to #7409)
Subject: RE: electrical failure


Posts: 82
Location: southern NH
Am assuming that you'd already wired CYCLE HALF of sidecar wiring harness to BMW before power loss. Check for a main fuse or fuseable link wire, which runs between battery and charging system on bike.
This may have blown due to an electrical leak in wiring you've already installed[crossed wire/frayed insulation, stray wire strand bridging connections, etc.]. Harness wiring could have an incorrect wire color/position in it causing your power drain, even though you did all connections 'by the book'. GOOD LUCK!

Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread


Copyright 2004-2008, The United Sidecar Association — Built by BarringtonPress — Send your suggestions and comments to the webmaster
USCA Web usage policy

(Delete all cookies set by this site)
Running MegaBBS ASP Forum Software
© 2002-2018 PD9 Software